Junctions 9 Version History

 

Junctions 9.0.1, 17th November 2015 [CURRENT MAINTENANCE VERSION]


AreaEnhancement
REPORTS Export to Word has been improved
REPORTS Most reports are quicker to generate
REPORTS A smaller font is used by default.  This leads to more compact but still readable reports.  If you prefer the original font size, you can restore it by changing File>Preferences>Reports>Font Size for Reports.
REPORTS ‘Turning Proportions’ and ‘Average PCU per Veh’ tables are now only printed if the ‘Detailed Demand Data’ option is ticked.  (File must also be in Advanced Mode.) 
REPORTS If the Input section is ticked, then the Traffic Demand section is automatically ticked and cannot be turned off.   This is to prevent cases that have been described to us where reports have been submitted which include all inputs and results other than turning proportion grids.  Such incomplete reports can potentially conceal discrepancies between the entered turning proportions and the results shown in reports.
REPORTS Various minor changes to appearance, column widths, justification etc.   Reports will tend to be neater than in previous versions when using the ‘Show arm and junction names’ display option.
REPORTS If using a single Analysis Set and multiple Demand Sets, the second Demand Set onwards now omits the superfluous headings for Geometries etc.  With large files this leads to shorter reports.
DIAGRAM For roundabouts, a new data overlay shows whole period results (as shown in the Summary Results screen) next to each arm.   This is turned on by default but can be switched off by clicking Overlays>Whole Period Results.  Adjust the size/position via Options>Text overlays>Whole period results.   The overlay uses the same colour coding (both background and foreground) as the corresponding Summary Result screen items.
DIAGRAM If working with multiple junctions, the junction ID size can now be altered independently (Options>Other>Junction ID Size)
DIAGRAM When exporting as a bitmap (right-click and use the Export menu), it is now possible to enter a desired resolution.  This can be used to generate large high quality bitmaps.
DIAGRAM Geometry measurement tool:  for some measurements you can now right-click on a control point to add more control points, giving finer control over the curvature of the construction lines.
UI Summary Results screen:  a new item in the Show menu provides a shortcut to the Sorting and Display section of the Data Outline where various options can be set.
UI Summary Results screen: priority PICADY streams (A-C etc) are no longer shown here. 
UI A Task List warning is now shown if the HV% is zero for all movements.
UI Header cells in data matrices (OD screen, Veh Mix screen etc) now allow long arm/junction names to word-wrap.  The Widths slider in each screen can still be used to control the column widths.
UI O-D matrices can now contain negative values.  This is ignored if running the traffic model but can be used to construct matrices for use with Demand Set relationships where negative growth is involved.
UI Each Analysis/Demand Set can now optionally be associated with a Colour property.  Edit the colour by clicking or double-clicking on the colour when showing the Analysis/Demand Set properties in the Data Editor or a Data Grid.  Colours are shown in the Data Outline and the main program dropdowns and can be used to visually distinguish between groups of sets.   This system can be turned off via Data Outline>Options>Sorting and Display>Colour Analysis/Demand Sets; this option has a corresponding file preference to set its value for new files.
UI All demand, flow and capacity inputs and outputs are now rounded to whole numbers if the current traffic units are per hour.   This leads to cleaner data grids and reports.  If working in per minute or per time segment, decimals are shown.   Decimals are also shown if a number between 0 and 1 is entered in the O-D screen, e.g. when entering linked junction turning proportions.    This behaviour can be overridden by changing File>Preferences>Appearance>Round flows to whole numbers.
UI If viewing PICADY stream results in a Data Grid, it is now possible to use the Filter menu to show only those streams associated with the current arm
UI The padlock on the O-D screen, Vehicle mix screen and Demand screen now has a third state that freezes the entire contents of the screen in a read-only state.  This can be used to view demand data for several Demand Sets at the same time.  (Show the O-D screen for the first Demand Set, use the padlock to freeze the screen, then show a second O-D screen and activate the second Demand Set, and so on.)  Clicking the padlock again will un-freeze the screen.
UI The choice of traffic units for new files can now be set via File>Preferences>General>Default Traffic Units / Default Traffic Units Period.  You can thus configure all new files to start off with units of e.g. PCU/hr or Veh/min according to your preference.    Once a new file has been created you can change the units as usual via the Data>Units screen.   
UI Analysis/Demand Set dropdowns are wider , to accommodate long names
UI Read data from Excel: a new option ‘Show details for all Demand Sets’ will launch a Data Grid showing the Excel options for all Demand Sets.  This is useful for quickly reviewing or editing the options across multiple Demand Sets.
UI TEMPRO Calculator:  Some authorities contain two zones with the same name.  The calculation for such zones was correct but if subsequently editing the TEMPRO properties, the selection would revert to the first of the two zones.  This has been fixed by appending the zone ID to the zone name.  If editing an existing file with TEMPRO properties you may need to re-set the zone.
MODEL Lane Simulation:  it is now possible to enter a Minimum/Maximum Capacity for PICADY lanes.  This can be used as a way of calibrating or adjusting the capacity of lanes.  Please note that this should be used with caution; please contact TRL for advice if necessary.
USER GUIDE Clarification has been added to the User Guide to confirm that queues in ARCADY/PICADY are the total on the arm regardless of lane distribution (UNLESS in lane simulation mode), that they include slowly moving vehicles and that they represent expected values.
ALL Various minor enhancements and speed-ups


AreaBug fix
UI Read data from Excel:  fixed bug where data would not be read when input units are set to Vehicles
UI Fixed bugs relating to results appearing to always be out of date (shown with a red background)
UI Fixed bug where Summary Results would exclude any Demand Sets that has a leading or trailing space in the Scenario Name
UI Demand Set relationships:  if using chained relationships, it was previously sometimes necessary to activate each set in the same order as the chain in order to guarantee correct results.  This has been fixed and correct results are now obtained regardless of the order in which sets have been activated.
UI If you customise the order of columns in a Data Grid, the order is no longer lost when changing Data Outline items or when adding/deleting items.
UI Copy/Paste All Demand Sets:  this now honours the current sort order for sets.  (Previously the order would sometimes use the internal file ordering and would not match the order shown in the Data Outline.)
UI Copy/Paste All Demand Sets:  fixed sporadic  timing problem where pasted data sometimes contained gaps if certain other applications running at the same time
UI Appearance of some screens when using 125% DPI scaling has been improved
UI Fixed longstanding issue where Glossary Screen can sometimes lock up other data editing screens
REPORTS PICADY priority streams now hidden in time segment results in reports if requested
REPORTS If running in comparison mode, some tables are now forced to be printed, to ensure that all differences between files/sets are shown.  (Previously some items such as intercept adjustments would only be shown in the comparison report if they existed in the master file.)
REPORTS Fixed bug where report would sometimes crash if it included graphs
REPORTS Fixed bugs where ‘Run Automatically’ property of Demand Sets was being ignored
REPORTS Fixed bug where report would crash if there was a “&” in the filename or path
MODEL Lane Simulation:  modification to the way results are calculated when capacity or demand is zero or very low.
MODEL Lane Simulation:   the type of vehicle and its destination is now set when the vehicle is first created.  Previously it was possible for a vehicle created in one time segment to cross the give-way line in a different time segment with a contradictory set of HV% or turning proportions, which sometimes led to an error.  This situation is now avoided.
MODEL Residual Capacity for PICADY junctions sometimes incorrectly referenced arms instead of streams; this has been fixed.
ALL Various minor bug fixes

 

 

Junctions 9.0.0, 14th May 2015

Please see the main Junctions 9 page for details about the new features in Junctions 9.